[SOLVED] [RVGL] ENVSTILL Bug ?

Report issues and bugs here.
User avatar
SebR
Posts: 149
Joined: Thu Dec 07, 2017 8:09 pm

[SOLVED] [RVGL] ENVSTILL Bug ?

Unread post by SebR » Sat Jan 05, 2019 3:39 pm

I found this bug on Trailer Park
Some Trolley are part of the world file (*.W)

On Re-Volt 1.2 Alpha 15.0420 they look like this near the blue car : Image

But on RVGL 18.1126a (legacy) no more trolley : Image

not tested with shader
wicked DROPBOX !!! If you found broken link PM me

AlicebanD an English voice that you must discover !!
User avatar
mmudshark
Posts: 15
Joined: Mon Dec 18, 2017 7:42 pm

Re: RVGL ENVSTILL BUG ?

Unread post by mmudshark » Wed Jan 16, 2019 6:45 pm

A different area of the track but a similar problem. Solid black carts using rvgl when racing online, different car textures on the carts racing offline. No difference with Shaders off or on. Laggee has the same invisible cart error as Seb, but nuc and I see the carts and only some have the texture problem. Track is normal using 1.2 re-volt.

Image
Image
User avatar
SebR
Posts: 149
Joined: Thu Dec 07, 2017 8:09 pm

Re: RVGL ENVSTILL BUG ?

Unread post by SebR » Wed Jan 16, 2019 6:58 pm

we get that bug on all mesh with "Envstill" flag set as "trailerparkk.bmp" and sometime it use the "car.bmp" as Envstill ...
wicked DROPBOX !!! If you found broken link PM me

AlicebanD an English voice that you must discover !!
User avatar
Huki
Developer
Posts: 209
Joined: Wed Dec 06, 2017 5:54 am
Discord: Huki#1668

Re: RVGL ENVSTILL BUG ?

Unread post by Huki » Wed Jan 16, 2019 11:45 pm

The problem is with the track itself. The world polys map to texture page 24 (in the original versions and v1.2, this used to be the ENVSTILL texture ID). It was a trick to be able to use 11 world textures - by setting ENVSTILL to "trailerparkk.bmp" and mapping polys to texture page 24, you get one more texture. But, mapping polys to textures outside (0 - 9) is not valid. When we increased the number of cars to 16 in RVGL, the ENVSTILL texture ID changed, so 24 is currently used for a car texture.

The upcoming RVGL release brings support for more than 10 world textures. This means you can now remap the bugged polys to ID 10 (i.e., <level>k.bmp) directly, no need to use ENVSTILL hack. It should fix the problem, but the track won't be compatible with older versions...
User avatar
SebR
Posts: 149
Joined: Thu Dec 07, 2017 8:09 pm

Re: RVGL ENVSTILL BUG ?

Unread post by SebR » Thu Jan 17, 2019 5:37 pm

ok the track pacth (compatible with old re-volt and new rvgl) will be ready for new RVGL release

Trailerpark update (1.1 / rvgl compatible)
don't forget to remove "custom" folder if you wish play it with 1.2
wicked DROPBOX !!! If you found broken link PM me

AlicebanD an English voice that you must discover !!
User avatar
Huki
Developer
Posts: 209
Joined: Wed Dec 06, 2017 5:54 am
Discord: Huki#1668

Re: RVGL ENVSTILL BUG ?

Unread post by Huki » Mon Feb 25, 2019 1:11 pm

SebR wrote:
Thu Jan 17, 2019 5:37 pm
ok the track pacth (compatible with old re-volt and new rvgl) will be ready for new RVGL release

Trailerpark update (1.1 / rvgl compatible)
don't forget to remove "custom" folder if you wish play it with 1.2
Thanks for the fix, works fine for me.
Post Reply