Page 1 of 1

[SOLVED] [RVGL] ENVSTILL Bug ?

Posted: Sat Jan 05, 2019 3:39 pm
by SebR
I found this bug on Trailer Park
Some Trolley are part of the world file (*.W)

On Re-Volt 1.2 Alpha 15.0420 they look like this near the blue car : Image

But on RVGL 18.1126a (legacy) no more trolley : Image

not tested with shader

Re: RVGL ENVSTILL BUG ?

Posted: Wed Jan 16, 2019 6:45 pm
by mmudshark
A different area of the track but a similar problem. Solid black carts using rvgl when racing online, different car textures on the carts racing offline. No difference with Shaders off or on. Laggee has the same invisible cart error as Seb, but nuc and I see the carts and only some have the texture problem. Track is normal using 1.2 re-volt.

Image
Image

Re: RVGL ENVSTILL BUG ?

Posted: Wed Jan 16, 2019 6:58 pm
by SebR
we get that bug on all mesh with "Envstill" flag set as "trailerparkk.bmp" and sometime it use the "car.bmp" as Envstill ...

Re: RVGL ENVSTILL BUG ?

Posted: Wed Jan 16, 2019 11:45 pm
by Huki
The problem is with the track itself. The world polys map to texture page 24 (in the original versions and v1.2, this used to be the ENVSTILL texture ID). It was a trick to be able to use 11 world textures - by setting ENVSTILL to "trailerparkk.bmp" and mapping polys to texture page 24, you get one more texture. But, mapping polys to textures outside (0 - 9) is not valid. When we increased the number of cars to 16 in RVGL, the ENVSTILL texture ID changed, so 24 is currently used for a car texture.

The upcoming RVGL release brings support for more than 10 world textures. This means you can now remap the bugged polys to ID 10 (i.e., <level>k.bmp) directly, no need to use ENVSTILL hack. It should fix the problem, but the track won't be compatible with older versions...

Re: RVGL ENVSTILL BUG ?

Posted: Thu Jan 17, 2019 5:37 pm
by SebR
ok the track pacth (compatible with old re-volt and new rvgl) will be ready for new RVGL release

Trailerpark update (1.1 / rvgl compatible)
don't forget to remove "custom" folder if you wish play it with 1.2

Re: RVGL ENVSTILL BUG ?

Posted: Mon Feb 25, 2019 1:11 pm
by Huki
SebR wrote:
Thu Jan 17, 2019 5:37 pm
ok the track pacth (compatible with old re-volt and new rvgl) will be ready for new RVGL release

Trailerpark update (1.1 / rvgl compatible)
don't forget to remove "custom" folder if you wish play it with 1.2
Thanks for the fix, works fine for me.