[SOLVED] [RVGL] Can't disable colorkeying

Report issues and bugs here.
User avatar
Instant
Posts: 28
Joined: Thu Dec 07, 2017 8:06 pm
Discord: Instant#4105
Location: void

[SOLVED] [RVGL] Can't disable colorkeying

Unread post by Instant » Sat Sep 15, 2018 9:58 pm

See the title. According to the documentation:
Use 'TEXTUREPROPS 1 1 1 0' to make texture page B use mipmapping, support mapping outside the boundaries and disable colorkeying (no pure-black alpha testing).
Added in version 18.0428a.
No matter what I do, the face will be invisible in-game. Tried this with both .bmp .png.
► Show Spoiler
► Show Spoiler
Yes, I have the lastest version of RVGL, and no, didn't use alpha/translucent flag on the image/face.
Uploaded the test track.
User avatar
Kiwi
Posts: 159
Joined: Thu Dec 07, 2017 9:04 pm
Contact:

Re: [RVGL] Can't disable colorkeying

Unread post by Kiwi » Sun Sep 16, 2018 1:17 pm

Instant, it seems you don't have the Shader version activated?

I've downloaded your testlevel, and tested it on my own.
Without Shaders enabled, the colorkey setting in the level.inf-file seems to be ignored.

Here screenshots from my tests:
► Show Spoiler
Maybe this should be stated in the RVGL documentation.
And this also means, that people who run a level who uses colorkeying without Shader-editions, will get a different experience.
I also wasn't aware of this. :?
Kiwi's :re-volt: Re-Volt Creations

Proud to be a Re-Volter since 1999 : )
User avatar
Instant
Posts: 28
Joined: Thu Dec 07, 2017 8:06 pm
Discord: Instant#4105
Location: void

Re: [RVGL] Can't disable colorkeying

Unread post by Instant » Sun Sep 16, 2018 4:51 pm

Fair enough, didn't test it with shaders. But yeah, it's not stated in the documentation, so to me it seems more like a bug. It's really useless if it doesn't work with the legacy renderer, since shaders is the one that's optional.
User avatar
607
Posts: 137
Joined: Thu Dec 07, 2017 5:49 pm

Re: [RVGL] Can't disable colorkeying

Unread post by 607 » Mon Sep 17, 2018 7:19 pm

Yeah, the legacy renderer should probably be made optional, so people need to enable it for MAKEITGOOD (I've heard there are some issues in some edit modes in the shader mode).
User avatar
Kiwi
Posts: 159
Joined: Thu Dec 07, 2017 9:04 pm
Contact:

Re: [RVGL] Can't disable colorkeying

Unread post by Kiwi » Thu Sep 20, 2018 10:37 am

Yes, the glitches in Makeitgood are also the reason, that I'm not using the Shader Edition by default. That's especially an issue when racing on tracks like Ranch, so the whole situation is kind of annoying.
Kiwi's :re-volt: Re-Volt Creations

Proud to be a Re-Volter since 1999 : )
User avatar
Marv
Site Admin
Posts: 186
Joined: Mon Dec 04, 2017 6:45 pm
Location: /home/marv

Re: [RVGL] Can't disable colorkeying

Unread post by Marv » Thu Sep 20, 2018 10:46 am

You can launch the game with -dev -noshader when you're using MAKEITGOOD until issues get resolved.
User avatar
Kiwi
Posts: 159
Joined: Thu Dec 07, 2017 9:04 pm
Contact:

Re: [RVGL] Can't disable colorkeying

Unread post by Kiwi » Thu Sep 20, 2018 7:34 pm

I thought I only can do it with the Shader = 0 or Shader = 1 line in the rvgl.ini. But this way it's much more comfortable, because I simply have to adjust my DEV shortcut.

This is very useful, Thanks Marv.
Kiwi's :re-volt: Re-Volt Creations

Proud to be a Re-Volter since 1999 : )
User avatar
Huki
Developer
Posts: 98
Joined: Wed Dec 06, 2017 5:54 am
Discord: Huki#1668

Re: [RVGL] Can't disable colorkeying

Unread post by Huki » Fri Oct 19, 2018 2:40 am

I think this is an oversight in the TEXTUREPROPS documentation. The colorkey attribute merely provides a hint to RVGL that the texture doesn't need colorkeying and hence it's safe to disable alpha testing. Alpha testing in shaders is a costly operation, so the game can make use of this information to conditionally enable it for textures that need it. There is however no guarantee that it actually gets disabled, and it currently only affects shader mode.

If you really want pure-black pixels to stay opaque, you must save your texture as PNG or 32-bit bitmap, which will let you control precisely which parts should be transparent (effectively disabling colorkeying). You could then set the TEXTUREPROPS values appropriately to benefit from the performance gains.

The upcoming RVGL release should slightly change this behavior (allowing you to definitively disable pure-black colorkeying on 24-bit bitmaps), but the above information still holds in other cases.

Also, the upcoming release should make shader renderer the default. :D
User avatar
Kiwi
Posts: 159
Joined: Thu Dec 07, 2017 9:04 pm
Contact:

Re: [RVGL] Can't disable colorkeying

Unread post by Kiwi » Tue Oct 30, 2018 7:11 am

See Huki's comment for solution - Also partly solved in 18.1020a.

Marked as [SOLVED]
Kiwi's :re-volt: Re-Volt Creations

Proud to be a Re-Volter since 1999 : )
User avatar
Instant
Posts: 28
Joined: Thu Dec 07, 2017 8:06 pm
Discord: Instant#4105
Location: void

Re: [SOLVED] [RVGL] Can't disable colorkeying

Unread post by Instant » Wed Oct 31, 2018 9:26 pm

I'm supposed to mark it as solved?
User avatar
Marv
Site Admin
Posts: 186
Joined: Mon Dec 04, 2017 6:45 pm
Location: /home/marv

Re: [SOLVED] [RVGL] Can't disable colorkeying

Unread post by Marv » Sun Nov 04, 2018 8:53 am

Yeah, feel free to. Either the OP or a moderator can do it.
Post Reply