[SOLVED] [RVGL] Sometimes deletes itself & breaks permissions

Report issues and bugs here.
User avatar
Mr. Burguers
Posts: 3
Joined: Mon Sep 03, 2018 10:32 pm
Discord: Mr. Burguers#4073

[SOLVED] [RVGL] Sometimes deletes itself & breaks permissions

Unread post by Mr. Burguers » Mon Sep 03, 2018 11:48 pm

UPDATE: The antivirus was causing these problems. I never suspected this, as there were no detection popups. I have now added RVGL to the antivirus's exclusion list. This should not happen again.

This has happened a total of 2 times now: first on 01/08, and today (03/09), both in version 18.0731a, Windows 7 64-bit.
When this bug happens, RVGL closes instantly, with no errors and/or Windows "stopped working" messages.
RVGL (path: C:\Users\Utilizador\Desktop\Jogos\Re-Volt\rvgl.exe) and another file that is/was in my Desktop (path: C:\Users\Utilizador\Desktop\LaunchRVGL.bat) are deleted. As far as I could see, those files were:
* not in the Recycle Bin,
* not in their original directories (checked with "dir /a"),
* not moved anywhere (searched my drive using Windows's search).
Trying to rename any file to
* "rvgl.exe" that is in "C:\Users\Utilizador\Desktop\Jogos\Re-Volt\",
* "LaunchRVGL.bat" that is in "C:\Users\Utilizador\Desktop\"
or copying a file named that way to those locations causes the following messages to appear:
0. ("If you change an extension, this file can become unusable") (only when testing through renaming) -> Yes
1. "To change this file's name you'll need to give administrator permission" -> Continue
2. UAC: "Do you want to allow this program to make changes to your computer?" "File Operation" -> Yes
3. "You need a permission to perform this action" "You require permission from Utilizador-PC\Utilizador [my account] to perform this action"
Note that renaming files to other names works correctly (even if only the extension is different).
Restarting the computer seems to fix the permission errors. Otherwise, I have to run "net user Administrador /active:yes" and log in normally. After doing the necessary changes, everything is back to normal.

The first time this bug happened was when I ran RVGL using "rvgl.exe -register" from cmd.exe. The RVGL icon either appeared and then vanished from the task bar, or it didn't appear at all.
The second time this happened was when I ran RVGL using "start rvgl.exe" from the mentioned "LaunchRVGL.bat". No launch flags were set. Then, I tried to join a Multi-Player lobby manually. The game froze for a while (presumably attempting to connect), and then closed.

Discord integration (implemented in this version) could be the source of this. The bug ocurred while trying to do things Discord integration supports (registering the URI and joining a Multi-Player game). However, since this bug happens so randomly, I'm guessing it's not possible to find out if this is true. It's still worth noting that Xarc also got this bug while trying to run RVGL with the "-register" flag. This, along with the "This only started happening in this version!", makes it more believable that Discord integration is somehow to blame here.