Page 1 of 1

[RVGL-MIG] Bugs in Makeitgood Lighting mode

Posted: Wed Jul 25, 2018 6:32 am
by Kiwi
Hello RVGL team,

I want to report some bugs in the Makeitgood Lighting mode.

1) Light sources doesn't send out light at all

In the Shader-edition, some light sources doesn't send out the light which is configured. Instead, the lights stay turned off. No chance at all, to turn them on. However, some light sources are working. I guess, that only the first lights added to the level are working. (Only a handful)

Here a screenshot from the shader edition.

Image

And here the same scene with shaders disabled:

Image

The issue only appears in Makeitgood Lighting mode. While normal racing, all lights are working as intended (also in shader edition).


2) Changing the RGB values of light sources is buggy.

The possibility to increase the speed of changing the RGB values by holding the shift-key only works with NUM-Lock Disabled, by pressing Shift and NUM-7 for example. As soon the NUM-Lock is enabled, only slow speed changing the values is possible.

This is the case for increasing all the colors (R, G, and B), and decreasing the colors R and B.

Decreasing the G value (NUM-5) by holding Shift and NUM-5 doesn't work at all. No matter, if NUM-Lock is Enabled or Disabled.

Ciao,

Kiwi

Re: [RVGL] Bugs in Makeitgood Lighting mode

Posted: Mon Aug 20, 2018 7:08 am
by Instant
I'm having the same problem regarding changing the RGB values. Will have to use 1.2 or an older version as working with lights is just painful as it is.

Re: [RVGL] Bugs in Makeitgood Lighting mode

Posted: Sat Sep 15, 2018 5:49 pm
by Instant
Please look into it if you have the time. It's extremely important for me.
I'm specifically talking about the bug where you can hardly change the green value of a light.

Re: [RVGL] Bugs in Makeitgood Lighting mode

Posted: Sat Sep 15, 2018 8:27 pm
by SebR
+1