Problem "hiccup" in RVGL

Report issues and bugs here.
User avatar
RobDin00
Posts: 21
Joined: Fri May 29, 2020 9:20 pm

Problem "hiccup" in RVGL

Unread post by RobDin00 » Fri May 29, 2020 9:34 pm

Hi everyone.
I'm writing because I have a problem of lag during the race in RVGL. After about 3 laps, RVGL registers totally in random way small lag. Like if the game has the "hiccup". I have tried to set the game at maximum setting and i have frame around 300 and 500, and I have tried also to set the game at minumum setting but I registers also the problem.
My pc has a gtx 1650, 16gb ram and ryzen 5 2600x.
I see that it could be stutturing. Please can you help me to fix this bug. I don't know why after 3 laps the game starts to lag totally in random zone of the track.
Thank you.
User avatar
revolting1
Posts: 54
Joined: Sun Mar 29, 2020 11:36 pm
Contact:

Re: Problem "hiccup" in RVGL

Unread post by revolting1 » Sat May 30, 2020 4:31 am

Try disabling the shaders and let us know what happens, in your folders profile search for rvgl.ini in it look for the entry shaders and set it to 0
User avatar
RobDin00
Posts: 21
Joined: Fri May 29, 2020 9:20 pm

Re: Problem "hiccup" in RVGL

Unread post by RobDin00 » Sat May 30, 2020 11:10 am

I have tried to disable the shaders. I've started a race of 6 laps in supermarket 1. The game goes smooth, but at the 6th lap I have seen hiccup 2 times. So I don't think that put shaders to 0, can fix my problem. Do you know other solution?
I have disabled only the string "Shaders = 1" to "Shaders = 0"
Maybe I have to disable all strings with the word "shader"?
User avatar
RobDin00
Posts: 21
Joined: Fri May 29, 2020 9:20 pm

Re: Problem "hiccup" in RVGL

Unread post by RobDin00 » Sat May 30, 2020 11:29 am

Ok, I have tried also to put to 0 all shaders strings. Nothing. This time the game has the hiccup at the 1st lap.
User avatar
VaidX47
Site Admin
Posts: 97
Joined: Mon Dec 04, 2017 6:52 pm
Discord: VaidX47#4043
Location: 333

Re: Problem "hiccup" in RVGL

Unread post by VaidX47 » Sat May 30, 2020 5:40 pm

Sounds more likely that it's affected by something running in the background on OS. Make sure to terminate any background processes that you do not use or need (in task manager if on Windows). Pay most attention to the ones that seem to be suspicious and use a lot of memory, CPU, GPU and disks for no reason. (Disk usage by specific processes can be checked in Resource Monitor, if running Windows).

If you know what you're doing, use msconfig.exe to disable third party services from running.

Anyways, I assume you're running Windows. If it was Linux, I wouldn't really expect such issues, unless faulty drivers or hardware itself, otherwise I don't know what could be the problem.

Also, if it definitely only applies to this game, then my post won't help much either, but you didn't give such info, so again, I only predict that you didn't test thoroughly on other games.
aka Vaid; >[MediaFire Stuff]<
User avatar
Avecezar
Posts: 44
Joined: Fri May 08, 2020 7:28 am

Re: Problem "hiccup" in RVGL

Unread post by Avecezar » Sat May 30, 2020 6:59 pm

Recently I have been playing Re-volt on my very old, about 15 years old laptop with Celeron processor and I experienced hiccups as well. There are periods of very smooth gameplay and periods with occasional hiccups. I just accepted the fact because it's old hardware. I use Windows 7 32 bit with no additional programs running in the background. Despite the hiccups I enjoy playing anyway. I understand that having modern hardware one may feel frustrated not having smooth experience. Try to experiment with disabling some programs running in the background to achieve quality gameplay you are looking for.
User avatar
RobDin00
Posts: 21
Joined: Fri May 29, 2020 9:20 pm

Re: Problem "hiccup" in RVGL

Unread post by RobDin00 » Sat May 30, 2020 10:46 pm

Before start revolt, i see in the task manager that the cpu is to 0%, ram 13%, disc 0% and gpu 0% of usage. So I don't think that there are programs in background that can slow down my pc and the game.
Also i register these hiccups only in rvgl. I tried to use Re-Volt 1.10 and it runs smooth.
User avatar
Avecezar
Posts: 44
Joined: Fri May 08, 2020 7:28 am

Re: Problem "hiccup" in RVGL

Unread post by Avecezar » Sat May 30, 2020 11:40 pm

Then it's weird. Especially that ver. 1.10 runs smoothly in exactly same environment. Hard to say what to do. Maybe test earlier version of RVGL and see if there's any improvement. If necessary test a few more previous releases. If you find a version running smoothly it will be the starting point to get more advanced help from developers.
User avatar
RobDin00
Posts: 21
Joined: Fri May 29, 2020 9:20 pm

Re: Problem "hiccup" in RVGL

Unread post by RobDin00 » Sun May 31, 2020 10:51 am

I've tested older build of rvgl, but there is the same problem. Do you think that I have to format my ssd and reinstall windows?
User avatar
VaidX47
Site Admin
Posts: 97
Joined: Mon Dec 04, 2017 6:52 pm
Discord: VaidX47#4043
Location: 333

Re: Problem "hiccup" in RVGL

Unread post by VaidX47 » Sun May 31, 2020 11:03 am

RobDin00 wrote:
Sat May 30, 2020 10:46 pm
Also i register these hiccups only in rvgl. I tried to use Re-Volt 1.10 and it runs smooth.
Hmm, have you tried 1.2 patch and see whether there is stuttering? It still runs in DirectX instead of OpenGL (RVGL). It won't solve the issue if you want to play with the latest features, just curious.
RobDin00 wrote:
Sun May 31, 2020 10:51 am
I've tested older build of rvgl, but there is the same problem. Do you think that I have to format my ssd and reinstall windows?
Cleaning up everything by reinstalling is probably the easiest solution, if you have no other clues. Of course there are some chances it won't solve anything, but then you might have a clue it's coming from the hardware (or BIOS configuration, whatever strange it could cause though) instead of software. I would put that off as a last measure, if you are absolutely sure it's happening only in RVGL and nowhere else else.
aka Vaid; >[MediaFire Stuff]<
User avatar
RobDin00
Posts: 21
Joined: Fri May 29, 2020 9:20 pm

Re: Problem "hiccup" in RVGL

Unread post by RobDin00 » Sun May 31, 2020 12:41 pm

So, now i try to install and run Re-Volt 1.2. After that I will write here if there is again the problem or not.
User avatar
RobDin00
Posts: 21
Joined: Fri May 29, 2020 9:20 pm

Re: Problem "hiccup" in RVGL

Unread post by RobDin00 » Sun May 31, 2020 1:20 pm

Okey, I've tried Re-Volt 1.2a15.0420 that is the last build of the 1.2 version. It is perfect. There aren't hiccups, and the game runs perfectly at 60fps smooth with max settings. So what do you think about hiuccps in RVGL version? What I have to do to fix the problem?
User avatar
Avecezar
Posts: 44
Joined: Fri May 08, 2020 7:28 am

Re: Problem "hiccup" in RVGL

Unread post by Avecezar » Sun May 31, 2020 7:41 pm

Then probably as VaidX47 suggested there must be issue with OpenGL.
Try disabling vsync first.
Maybe you could also find a game or benchmark running solely on OpenGL and test it to see if you run into the same problem.
User avatar
RobDin00
Posts: 21
Joined: Fri May 29, 2020 9:20 pm

Re: Problem "hiccup" in RVGL

Unread post by RobDin00 » Sun May 31, 2020 8:23 pm

The problem there is also with v-sync off.
There is a way to fix the OpenGL of my graphic card?
User avatar
RobDin00
Posts: 21
Joined: Fri May 29, 2020 9:20 pm

Re: Problem "hiccup" in RVGL

Unread post by RobDin00 » Sun May 31, 2020 8:43 pm

I have tested my openGL, with the benchmark of OpenGL extensions viewer, and I have 60fps in all of the openGL from OpenGL 3.0 to 4.6. Also I have different game that use openGL and there isn't the problem of hiccup like in RVGL
User avatar
revolting1
Posts: 54
Joined: Sun Mar 29, 2020 11:36 pm
Contact:

Re: Problem "hiccup" in RVGL

Unread post by revolting1 » Mon Jun 01, 2020 12:33 pm

I haven't look into it but you could try another driver for your graphics card and see if that solves the problem, whether an older or newer version it might do the trick, newer should be preferred though
User avatar
607
Posts: 324
Joined: Thu Dec 07, 2017 5:49 pm

Re: Problem "hiccup" in RVGL

Unread post by 607 » Mon Jun 01, 2020 5:52 pm

I hope you can fix it! But I don't currently have any ideas except switching to a different GPU. :P
User avatar
RobDin00
Posts: 21
Joined: Fri May 29, 2020 9:20 pm

Re: Problem "hiccup" in RVGL

Unread post by RobDin00 » Sun Jun 07, 2020 4:02 pm

I think that this problem is caused by the new version of windows 10 2004. I've talked with another guy that has installed this version of windows and now he has also this problem of hiccup.
User avatar
revolting1
Posts: 54
Joined: Sun Mar 29, 2020 11:36 pm
Contact:

Re: Problem "hiccup" in RVGL

Unread post by revolting1 » Sun Jun 07, 2020 9:40 pm

More than likely, you could try installing a fresh copy of rvgl just the game and not mod packs to see if it solves the problem,

To confirm it is a windows problem try installing lubuntu or ubuntu, as always do a backup before you do it though
User avatar
RobDin00
Posts: 21
Joined: Fri May 29, 2020 9:20 pm

Re: Problem "hiccup" in RVGL

Unread post by RobDin00 » Mon Jun 08, 2020 12:52 am

I've installed a clean copy of rvgl, with only stock cars and tracks. There are these random hiccups during the races.
I'm sure that is a problem connected with the 2004 version of Windows 10. Maybe, in future will be a patch for rvgl that will fix this problem
User avatar
Avecezar
Posts: 44
Joined: Fri May 08, 2020 7:28 am

Re: Problem "hiccup" in RVGL

Unread post by Avecezar » Mon Jun 08, 2020 2:34 pm

Please be so kind to inform us when you solve this issue, it might be helpful for others.

Maybe there will not be a dedicated patch for RVGL but Microsoft will fix problem they introduced with the latest release.
User avatar
revolting1
Posts: 54
Joined: Sun Mar 29, 2020 11:36 pm
Contact:

Re: Problem "hiccup" in RVGL

Unread post by revolting1 » Mon Jun 08, 2020 2:53 pm

Disable "threaded" in the rvgl.ini setting it to 0 it's located in the profiles folder, set "Vsync" to 1 and "limitlatency "to 2
User avatar
RobDin00
Posts: 21
Joined: Fri May 29, 2020 9:20 pm

Re: Problem "hiccup" in RVGL

Unread post by RobDin00 » Tue Jun 09, 2020 10:23 am

I've done it, but doesn't fix the problem. I'm sure that a problem connected with Windows 10 2004
User avatar
RobDin00
Posts: 21
Joined: Fri May 29, 2020 9:20 pm

Re: Problem "hiccup" in RVGL

Unread post by RobDin00 » Tue Jun 09, 2020 10:58 pm

Today i've installed an update of the windows 10 2004. Now the game seems go better. I've tried 2 times the Platinum cup: the first time i haven't seen any hiccup, and the second time i have seen only one time the hiccup during supermarket 1. So the problem turn around the version 2004 of Windows 10.
User avatar
Avecezar
Posts: 44
Joined: Fri May 08, 2020 7:28 am

Re: Problem "hiccup" in RVGL

Unread post by Avecezar » Wed Jun 10, 2020 8:12 am

I've tested RVGL on fresh install of windows 10 ver. 2004 64 bit with all additional packs, ran a couple of laps and haven't experienced any hiccups. It seems then that the problem you mentioned is not directly connected with that windows version.
Post Reply