Problem "hiccup" in RVGL

Report issues and bugs here.
User avatar
revolting1
Posts: 54
Joined: Sun Mar 29, 2020 11:36 pm
Contact:

Re: Problem "hiccup" in RVGL

Unread post by revolting1 » Wed Jun 10, 2020 8:16 am

Next thing you could try is:
setting threaded to 1
Vsync to 0
User avatar
RobDin00
Posts: 21
Joined: Fri May 29, 2020 9:20 pm

Re: Problem "hiccup" in RVGL

Unread post by RobDin00 » Wed Jun 10, 2020 10:48 am

there is an update that maybe has fixed my problem.Yesterday I installed from windows update a patch for windows 2004 that has installed windows 10 2004 build 19041.329. Now, I have runned 2 times the platinum cup and I haven't seen any hiccups. The game seems run smooth like first, when I had the windows 10 1909.
User avatar
Huki
Developer
Posts: 345
Joined: Wed Dec 06, 2017 5:54 am
Discord: Huki#1668

Re: Problem "hiccup" in RVGL

Unread post by Huki » Mon Jun 29, 2020 5:54 am

I'm glad the issue seems solved for now. I'm reading that the 2004 update introduced a lot of issues in general, so that could just be it. In case the issue comes back, I have a few points in mind:
  • You mentioned "i have frame around 300 and 500", which implies v-sync was off. This could have overheated the GPU, or triggered something related to power management and caused the stuttering.
  • You mentioned other OpenGL games worked well. Did they work well even with the 2004 update?
  • The first step for troubleshooting graphical issues is to make sure you have the latest RVGL version, then delete rvgl.ini and let it regenerate with default settings.
  • If you suspect something wrong with your system's OpenGL support, try the optional Direct3D backend and see if it works better. To enable it, edit rvgl.ini and set 'Shaders = 1' and 'Profile = 3'.
User avatar
RobDin00
Posts: 21
Joined: Fri May 29, 2020 9:20 pm

Re: Problem "hiccup" in RVGL

Unread post by RobDin00 » Mon Jun 29, 2020 8:39 am

Hi Huki.
I must say that after the last patch for windows 10 2004, I have again some hiccup during the races, also that is less present as before. I have this problem only with RVGL. I don't think that I have problem with my OpenGl. I have the last version of RVGL. Now I'll try to do these steps that you have wrotten.
User avatar
RobDin00
Posts: 21
Joined: Fri May 29, 2020 9:20 pm

Re: Problem "hiccup" in RVGL

Unread post by RobDin00 » Mon Jun 29, 2020 8:46 am

With shaders= 1 and Progile=3, I see again these hiccups of frame. I'm sure that is a problem between RVGL and the 2004 update.
All my game run smooth. Only RVGL has this problem.
User avatar
Huki
Developer
Posts: 345
Joined: Wed Dec 06, 2017 5:54 am
Discord: Huki#1668

Re: Problem "hiccup" in RVGL

Unread post by Huki » Mon Jun 29, 2020 9:59 am

RobDin00 wrote:
Mon Jun 29, 2020 8:46 am
With shaders= 1 and Progile=3, I see again these hiccups of frame. I'm sure that is a problem between RVGL and the 2004 update.
All my game run smooth. Only RVGL has this problem.
Are you sure you have V-Sync on? What is your frame rate in-game?
User avatar
RobDin00
Posts: 21
Joined: Fri May 29, 2020 9:20 pm

Re: Problem "hiccup" in RVGL

Unread post by RobDin00 » Mon Jun 29, 2020 11:30 am

Yes, i'm sure. Fps are 59/60. When I see stuttering, the frame sometimes goes to 57, 61, 58 ecc. when the game is smooth I Have frames at 59 and 60.
User avatar
Huki
Developer
Posts: 345
Joined: Wed Dec 06, 2017 5:54 am
Discord: Huki#1668

Re: Problem "hiccup" in RVGL

Unread post by Huki » Wed Jul 01, 2020 4:38 pm

Can you upload your rvgl.ini and re-volt.log files? Also, which other OpenGL games have you tried on this system?
User avatar
RobDin00
Posts: 21
Joined: Fri May 29, 2020 9:20 pm

Re: Problem "hiccup" in RVGL

Unread post by RobDin00 » Thu Jul 02, 2020 12:33 am

Huki wrote:
Wed Jul 01, 2020 4:38 pm
Can you upload your rvgl.ini and re-volt.log files? Also, which other OpenGL games have you tried on this system?
I have tried Mafia II and Euro Track Simulator 2, and these games run perfectly.
How can I post the .ini file and the log file? I don't see the option to allocate these 2 files.
User avatar
Avecezar
Posts: 44
Joined: Fri May 08, 2020 7:28 am

Re: Problem "hiccup" in RVGL

Unread post by Avecezar » Thu Jul 02, 2020 10:33 am

How can I post the .ini file and the log file? I don't see the option to allocate these 2 files.
You can copy / paste as text into
[spoil][/spoil]
or
[quote][/quote]
brackets.
User avatar
RobDin00
Posts: 21
Joined: Fri May 29, 2020 9:20 pm

Re: Problem "hiccup" in RVGL

Unread post by RobDin00 » Thu Jul 02, 2020 10:58 am

Huki wrote:
Wed Jul 01, 2020 4:38 pm
Can you upload your rvgl.ini and re-volt.log files? Also, which other OpenGL games have you tried on this system?
I have send you in discord my log and .ini files
Post Reply