RVGL crash after loading "dodgy poly texture" (after rvgl v20 update)

Report issues and bugs here.
Posts: 1
Joined: Mon Jul 27, 2020 2:25 am

RVGL crash after loading "dodgy poly texture" (after rvgl v20 update)

Unread post by laurel2195 » Mon Jul 27, 2020 2:36 am


This is my first post on this forum so apologies if my topic is lacking in structure.
I just updated to RVGL v20.0430a (so my installation is fresh), and noticed that a lot of custom tracks I previously installed now crash on load. This is the case for Quake, Schoolout, Toyboat arcade (ship0), and a few other.

Looking at the error logs right after the problem happens, I notice that in all these tracks, the last log is always
Warning: Dodgy poly texture num 29806 in levels/quake/.armchair.prm (or any other level that crashes).

Seems like the texture number is always the same (tho I might be wrong). I also noticed that there is always 3 dodgy poly textures warnings, and then the game crashes silently (no error messages or alerts).

I tried redownloading quake and the other custom tracks, and here are some things I also tried (hoping to troubleshoot and find the issue).
- tried different resolutions
- tried to delete my profile and create a new one from scratch
- tried various cars, and also tried tons of settings (number of cars) and other rendering settings, but nothing seemed to make a difference

Anybody is also experiencing some tracks crashing because of dodgy texture warning? I am a bit out of ideas, and any help would be greatly appreciated.

Many thanks!
User avatar
Site Admin
Posts: 81
Joined: Mon Dec 04, 2017 6:52 pm
Discord: VaidX47#4043
Location: 333

Re: RVGL crash after loading "dodgy poly texture" (after rvgl v20 update)

Unread post by VaidX47 » Mon Jul 27, 2020 7:48 am

Files starting with a dot should not exist in these track folders. Sounds dodgy to me.
The game tries to load all *.prm+*.ncp files (instances) from the level folder, no matter how they are named, unlike with other main track files (be consistent with the folder name). So if there's one with weird data in it (either corruption, created by virus/malware and etc.), the game will very likely hang while loading.

Remove those files
or redownload the track from Re-Volt Zone or RVXTG, reinstall it (by deleting old folder first) and try again.
aka Vaid; >[MediaFire Stuff]<
Post Reply