[RVGL 19.0430] No fallback for ENVSTILL / ENVROLL on legacy renderer

Report issues and bugs here.
User avatar
EvgenKo423
Posts: 24
Joined: Sun May 05, 2019 11:14 am

[RVGL 19.0430] No fallback for ENVSTILL / ENVROLL on legacy renderer

Unread post by EvgenKo423 » Sat May 18, 2019 8:15 pm

Don't know if you'll consider it a worthwhile bug, but I'll report it anyway. :roll:

If some tracks' .inf file contains an ENVSTILL / ENVROLL parameter pointing to a non-existent image, on legacy renderer cars and some other objects will have a very bright glow (looks like the game uses some pure white texture instead of falling back to default one):
Image Donut Plains 3 There is no such issue on shader renderer, however.
User avatar
VaidX47
Site Admin
Posts: 57
Joined: Mon Dec 04, 2017 6:52 pm
Discord: VaidX47#4043
Location: 333

Re: [RVGL 19.0430] No fallback for ENVSTILL / ENVROLL on legacy renderer

Unread post by VaidX47 » Tue May 21, 2019 5:51 pm

That's because missing textures are shown as transparent in shader renderer, while legacy displays pure white.
It was like that in the original game. These two properties should not be added if texture is missing.
aka Vaid; >[MediaFire Stuff]<
User avatar
SebR
Posts: 149
Joined: Thu Dec 07, 2017 8:09 pm

Re: [RVGL 19.0430] No fallback for ENVSTILL / ENVROLL on legacy renderer

Unread post by SebR » Mon Jun 24, 2019 9:51 am

in that case missing ENVSTILL / ENVROLL is because it look for "Mid-sea Island" track folder ...
wicked DROPBOX !!! If you found broken link PM me

AlicebanD an English voice that you must discover !!
User avatar
EvgenKo423
Posts: 24
Joined: Sun May 05, 2019 11:14 am

Re: [RVGL 19.0430] No fallback for ENVSTILL / ENVROLL on legacy renderer

Unread post by EvgenKo423 » Mon Jun 24, 2019 5:01 pm

I know and I've fixed it, but that is not the case.
Post Reply