Problems during installation on Linux Mint

Ask for help regarding any Re-Volt topic here.
User avatar
Avecezar
Posts: 73
Joined: Fri May 08, 2020 7:28 am
Contact:

Problems during installation on Linux Mint

Unread post by Avecezar » Mon May 03, 2021 8:57 pm

Hi,

Im trying to install rvgl on Linux Mint using script "install_rvgl.py".

I encounter the following errors:

1.
Package libfluidsynth1 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package 'libfluidsynth1' has no installation candidate
Error loading libfluidsynth.so.1: libfluidsynth.so.1: cannot open shared object file: No such file or directory

I checked that 'libfluidsynth1' has been replaced with 'libfluidsynth2' which is installed on my system.
2.
Fixing filenames...
./cars/phim_ultraRV was not renamed

If you come with suggestion then please make it clear to new Linux user ;)

EDIT
Game works anyway without installation of libfluidsynth1.
SDeG
User avatar
ZipperZbieracz
Posts: 267
Joined: Thu Dec 21, 2017 12:38 pm
Discord: ZipperZbieracz#9343

Re: Problems during installation on Linux Mint

Unread post by ZipperZbieracz » Fri May 07, 2021 12:28 pm

I asked Huki about this in December 2020 and what he answered me:

"RVGL optionally uses fluidsynth 1 to play midi files. Most distros have switched to fluidsynth 2, which is not backwards compatible and the game doesn't support it. But the error is harmless. It shouldn't prevent the game from running. I plan on supporting fluidsynth 2 eventually."

And when it comes to some files being "not able" to change name to lowercase, I think when you go to the folder the file has then 2 versions – one with uppercases, one with fixed lowercases, so it's not able to fix filename to lowercase because there is already a lowercase copy of that file in the folder. Why it does that I don't know.
Post Reply