Custom Track Properties: Velocity

Ask for help regarding any Re-Volt topic here.
User avatar
I Spy
Posts: 5
Joined: Sun Sep 15, 2019 5:38 pm

Custom Track Properties: Velocity

Unread post by I Spy » Wed Oct 16, 2019 2:56 am

I'm using a properties.txt file in a custom track. However, I can't get the velocity function to work. I've made sure that "Moves" is set to "true", and use multiples of 100.0 for the velocity values.

Here's what I have in the txt:

Code: Select all

{
    MATERIAL {
      ID              1
      Name            "test"
      Skid            true
      Spark           false
      Corrugated      false
      Moves           true
      Dusty           false
      Roughness       1
      Grip            0.9
      Hardness        1
      SkidSound       6
      ScrapeSound     5
      CorrugationType 4
    SkidColor       100 0 0
    Velocity        0.0 0.0 300.0
    }
}
I used colorful skid marks to confirm the new material is being read - it's just not moving the car.
I'm also using RVGL version 19.1001a
User avatar
Wichilie
Posts: 60
Joined: Sat Feb 24, 2018 12:52 pm

Re: Custom Track Properties: Velocity

Unread post by Wichilie » Wed Oct 16, 2019 8:17 am

I had a look at the properties of one of the stock conveyers and it uses the following velocity: 0.000000 -500.000000 0.000000. Yours is 0.000000 0.000000 300.000000, so you might be telling the game to move cars up into the air, instead of sideways. Try changing it to 0.000000 300.000000 0.000000 or 300.000000 0.000000 0.000000 and see if that works.
User avatar
I Spy
Posts: 5
Joined: Sun Sep 15, 2019 5:38 pm

Re: Custom Track Properties: Velocity

Unread post by I Spy » Wed Oct 16, 2019 1:59 pm

I changed the values, and they don't work, either.
User avatar
Gotolei
Posts: 34
Joined: Mon Dec 04, 2017 9:55 pm
Discord: Gotolei#0819
Location: The New Are

Re: Custom Track Properties: Velocity

Unread post by Gotolei » Wed Oct 16, 2019 5:41 pm

Just did a bunch of testing on this, modifying the existing conveyors from muse2. Given a coordinate system of X/Y/Z, X and Z are always relative to the world (they pull in the same direction regardless of the conveyor's direction itself, be it sideways, frontways, flipped turnways etc). If the conveyor is flat then this is fine, but if you're trying to do a slope then Y is what you'll want to play with (negative values pull upwards, positive values push downwards). From what I'm seeing, Y has no effect on flat surfaces.

Also possibly worth noting: I generally had to restart the level twice to get it to actually reload properties.txt. Dunno if that's actually a thing or not, but it only takes an extra second or two.
Image
User avatar
I Spy
Posts: 5
Joined: Sun Sep 15, 2019 5:38 pm

Re: Custom Track Properties: Velocity

Unread post by I Spy » Wed Oct 16, 2019 8:27 pm

I tried editing existing conveyors:
In my test world, both supermarket conveyors don't move, regardless of the x or z values I enter.
The museum conveyors do move, but their speed and direction don't change when I edit the y value.

However, I was able to change the skid mark color on all conveyors, so it should be reading the properties.txt just fine.
Gotolei wrote:
Wed Oct 16, 2019 5:41 pm
Also possibly worth noting: I generally had to restart the level twice to get it to actually reload properties.txt. Dunno if that's actually a thing or not, but it only takes an extra second or two.
This doesn't seem to happen to me, but I've been restarting my world when I update it now, can't be too sure.
User avatar
I Spy
Posts: 5
Joined: Sun Sep 15, 2019 5:38 pm

Re: Custom Track Properties: Velocity

Unread post by I Spy » Sat Oct 26, 2019 3:07 pm

After taking a short break, I tried making a diagonal conveyor. But I still can't recreate movement like the market conveyors.

Image

A. The surfaces "CONVEYOR_MARKET1" and "CONVEYOR_MARKET2" act as they do in the stock tracks if the velocity is not edited.

B. When I edit the velocity properties of another surface, like "DIRT1", it has no effect.

C. My end goal is to edit any given surface ID to be a conveyor that moves diagonal in relation to the other conveyors by combining X and Z axis forces.

I have no idea if I'm doing something wrong, or if the conveyor property itself is broken and needs to be patched.
Post Reply